[SOLVED] 404 error on O365 subsite lists

May 11, 2012 at 2:51 PM

P1 account.

Subsite inherits web site permissions.

Coordinator
Jun 5, 2012 at 5:54 PM

Where exactly you get the 404. What type of list show the failure and can you provide also the url?

Jun 6, 2012 at 1:59 AM
Edited Jun 6, 2012 at 1:59 AM

Now I don't get the 404 but P1 team site lists and libraries both show the red error I mentioned in the other discussion:

Web does not allow anonymous access.

Lib: http://wb3.sharepoint.com/TeamSite/Docs%20private/Forms/AllItems.aspx

List: http://wb3.sharepoint.com/TeamSite/Lists/News/AllItems.aspx

Jun 6, 2012 at 9:38 PM

Spoke too soon - now on an E3 account I am getting  a 404 when I click the anon access icon.

It's a blog site list at:

https://wb2.sharepoint.com/blog/Lists/Posts/AllPosts.aspx

I was sure this already had anon permissions.

Coordinator
Jun 13, 2012 at 5:25 PM

After some investigation I figure out the root cause for the problem "Web does not allow anonymous access".

Please see the following blog post for the solution

http://www.fiechter.eu/blog/Lists/Posts/Post.aspx?ID=26&mobile=0

I couldn't reconstruct the 404 failure, right now I tried it on an E3 account and it was working.

Jun 27, 2012 at 4:09 AM

Sorry for the delay, I didn't get a note you'd replied.

All the urls I mentioned were of course not in public site collections - I must've thought I could make team site libs anonymous for some reason!

Thanks for the follow up. It's a brilliant solution.